LG MS400D-P

LG MS400D-P

Postby Pet67 » 19 Nov 2019, 16:49

Приветствую всех!

Попал мне в руки сабжевый девайс. Это медиаплеер с внешней корзиной для 3,5" дисков SATA для записи телевизионных программ в системе DVB-T.
Есть доступ через telnet

Вот что выдает о себе:
| +
# cat /proc/version
Linux version 2.6.12.6-VENUS (root@localhost.localdomain) (gcc version 3.4.4 mipssde-6.02.03-20050629) #9 Mon Apr 18 16:21:54 KST 2011

# cat /proc/cpuinfo
system type : Realtek Venus
processor : 0
cpu model : MIPS 24K V7.8
BogoMIPS : 269.51
wait instruction : yes
microsecond timers : yes
tlb_entries : 32
extra interrupt vector : yes
hardware watchpoint : yes
ASEs implemented : mips16
VCED exceptions : not available
VCEI exceptions : not available

# cat /proc/mtd
dev: size erasesize name
mtd0: 002b2000 00010000 "Partition_000"
mtd1: 00b0e000 00010000 "Partition_001"
mtd2: 00100000 00010000 "Partition_002"
mtd3: 00140000 00010000 "Partition_003"
mtd4: 01000000 00010000 "disc"

# cat /proc/meminfo
MemTotal: 250728 kB
MemFree: 85696 kB
Buffers: 64044 kB
Cached: 13772 kB
SwapCached: 0 kB
Active: 43860 kB
Inactive: 35636 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 250728 kB
LowFree: 85696 kB
SwapTotal: 32 kB
SwapFree: 32 kB
Dirty: 0 kB
Writeback: 0 kB
Mapped: 6132 kB
Slab: 6060 kB
CommitLimit: 125396 kB
Committed_AS: 6324 kB
PageTables: 524 kB
VmallocTotal: 1048548 kB
VmallocUsed: 1336 kB
VmallocChunk: 1046924 kB

# free
total used free shared buffers
Mem: 250728 165032 85696 0 64044
Swap: 32 0 32
Total: 250760 165032 85728

# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 11.1M 11.1M 0 100% /
/dev/mtdblock/2 1.0M 256.0k 768.0k 25% /usr/local/etc
/dev/rd/0 40.0k 40.0k 0 100% /mnt/rd
/dev/scsi/host1/bus0/target0/lun0/part1 1.8T 7.3G 1.8T 0% /tmp/hdd/volumes/HDD1
/dev/scsi/host1/bus0/target0/lun0/part3 16.0G 1.0M 16.0G 0% /tmp/hdd/livepause
/dev/scsi/host1/bus0/target0/lun0/part4 151.9M 4.0M 140.0M 3% /tmp/hdd/root


Судя по всему медиаплеер на Realtek 1186.

Фото внутренностей:

Image

Можно скачать проследнюю прошивку для него:

http://gscs-b2c.lge.com/downloadFile?fileId=KRSWD000010995-b1-a1.zip

Можно его немного облагородить? Ибо фирмварь устарела - ни Picasa, ни встроенный клиент Youtube не работают.
Не получилось запустить воспроизведение музыки в формате flac.
Pet67
 
Posts: 2
Joined: 25 Oct 2015, 18:12

Re: LG MS400D-P

Postby Virtual » 20 Nov 2019, 21:03

смущает отсутствие NAND флеш!.... если NOR всего 16 метров ой не весело туда что либо установить :D
марсы: HDS7 (смотрелка AMP скин vrt уже без вариантов)
HDR12 AMP (обычно сервер с RAM 256 и возможностью подключить 2 SATA диска 2T+)
XTR PRO(AMP, HTTP(S) NFS SMB FTP сервер +trans2.90 + 2 SATA диска 2T+
сатурны: XTR Prodigy, R6S(512Mb_NAND), HD900A(_MD*) прошивка
User avatar
Virtual
 
Posts: 6476
Joined: 01 Oct 2010, 17:17
Location: UFA RU

Re: LG MS400D-P

Postby const » 21 Nov 2019, 00:58

Так там в nor'е только необходимый минимум, остальное здесь:
Pet67 wrote:/dev/scsi/host1/bus0/target0/lun0/part4 151.9M 4.0M 140.0M 3% /tmp/hdd/root[/spoiler]

КМК.
ASUS O!Play (R1). AMP13, Vrtn.
const
 
Posts: 27
Joined: 01 Dec 2011, 22:06

Re: LG MS400D-P

Postby lymax » 21 Nov 2019, 17:11

В прошивке
<signature>RTD1183</signature>

dmesg выложи
Марсы: 2*Emtec Movie Cube S800H (amp_r12 vrtn + amp_r12 noGUI[NFS/Samba/FTP/Trans])
Сатурны: Iconbit XDS73D + eGreat R6S Pro (ампс + скин 3Dgui)
+ eGreat R6S Pro (ампс ногуй) + 2*eGreat R6S для тестов
Сеть/Инет: LAN / WLAN 300Mb / ADSL 16Mb
User avatar
lymax
 
Posts: 245
Joined: 12 Jun 2012, 00:10

Re: LG MS400D-P

Postby Pet67 » 22 Nov 2019, 16:29

С полным логом проблемы. syslogd не запущен и как поместить его в автозагрузку непонятно.
А у dmesg маленький буфер. Пока захожу телнетом, в него сыпет всякий мусор, удаляя начальные строки загрузки

dmesg | +
# dmesg
de is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
TTDecodeFilter::Pause
flush TELETEXT begin
TTPinFlush...
TTPinFlush...return 1.
flush TELETEXT end
flush SPIC begin
flush SPIC end
flush AUDIO begin
[AUDIO WARNING] <4><APP> Reset cgms_change_flag when APP flush
flush AUDIO end
flush VIDEO begin
flush VIDEO end
******** Updated PID Filter List ********
[CInputDTV.cpp 2792] set EVENT_FLUSH
flush TELETEXT begin
TTPinFlush...
TTPinFlush...return 1.
flush TELETEXT end
flush SPIC begin
flush SPIC end
flush AUDIO begin
[AUDIO WARNING] <4><APP> Reset cgms_change_flag when APP flush
flush AUDIO end
flush VIDEO begin
flush VIDEO end
TTDecodeFilter::Run
src/tpif_NeptuneTP.cpp : 281 : StreamControl : TSOUT MUTE <OFF>
src/NeptuneTP.cpp, 1455, StreamControl: Start Streaming
RootAP::Activate, internal HDD is not ready, DONT start timeshift
In my system...
<APP> switch focus: 0xfffffffe -> 0x00000000
<APP> max_out_samplerate type 0x00000001
RP=0x4800000 WP=0x4800000
In my system...
CheckNoHddModelSata0Connection false
CheckNoHddModelSata0Connection line=87, NoHddSata0OffCount=2
============ CDtvState::setSubtitle, type(0), value(0) showVideo(1)

@@@[AbstractAP.cpp:1752:Init():16617]@@@

AMute(1)
IN : /tmp/net
Create /tmp/net Ok!!!
In my system...
GetDeviceUp 0 flag : 0x1043
SetupClass::GetInstance()->GetNetEth0DHCPEnable() = 1
Click eth0 DHCP IP and DNS
In my system...
info, udhcpc (v0.9.9-pre) started
Error in threshold value: 0...
WatchDog does not receive signal for 12 seconds, value: 0
In my system...
CheckNoHddModelSata0Connection false
CheckNoHddModelSata0Connection line=87, NoHddSata0OffCount=3
1. start remap DVR zone...
fastmode is 100...
map_done is 188...
map_fail is 0...
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
req: 1c4000, get: 200000
reclaim size: 20000
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
1. start remap DVR zone...
fastmode is 100...
map_done is 0...
map_fail is 0...
=======================
Power On Count : 8
=======================

@@@[AbstractAP.cpp:1781:Init():18349]@@@


@@@[AbstractAP.cpp:1806:Init():18350]@@@

In my system...
DeleteStandbyOtaFirstBootFlagFile, success, cmd=rm -f /usr/local/etc/dvdplayer/standby_ota_first_boot

@@@[AbstractAP.cpp:1931:Init():18442]@@@

0/4 - /proc/net/rtl8187/wlan0
1/4 - /proc/net/rtl819xU/wlan0
2/4 - /proc/net/rtl819xSU/wlan0
3/4 - /proc/net/rtl819xE/wlan0

@@@[AbstractAP.cpp:1953:Init():18472]@@@

=== GPIO 102, mute = 0
In my system...
ifconfig eth0 169.254.10.172
[usb_param] setting for mars
Setting for MARS-B
[usb_param] set port two for host!
[usb1_param] usbphy reg 32, set sh = 0xf, get sh = 0xf, 4bit
[usb1_param] usbphy reg 35, set src = 0x7, get src = 0x7, 3bit
[usb1_param] usbphy reg 36, set senh = 0xd, get senh = 0xd, 4bit
[usb1_param] usbphy reg 32, set sen = 0x8, get sen = 0x8, 4bit
[usb1_param] usbphy reg 33, set dr = 0x0, get dr = 0x0, 3bit
[usb2_param] usbphy reg 32, set sh = 0xf, get sh = 0xf, 4bit
[usb2_param] usbphy reg 35, set src = 0x7, get src = 0x7, 3bit
[usb2_param] usbphy reg 36, set senh = 0xd, get senh = 0xd, 4bit
[usb2_param] usbphy reg 32, set sen = 0x8, get sen = 0x8, 4bit
[usb2_param] usbphy reg 33, set dr = 0x0, get dr = 0x0, 3bit
route add -net 0.0.0.0 netmask 0.0.0.0 eth0
debug, Sending discover...
debug, Sending select for 192.168.6.104...
ehci_hcd ehci_hcd: EHCI Host Controller
ehci_hcd ehci_hcd: new USB bus registered, assigned bus number 1
ehci_hcd ehci_hcd: irq 2, io mem 0xb8013000
ehci_hcd ehci_hcd: park 0
ehci_hcd ehci_hcd: USB 0.0 initialized, EHCI 1.00, driver 10 Dec 2004
info, Lease of 192.168.6.104 obtained, lease time 259200
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
hub : individual port power switching
hub : individual port over-current protection
Error in threshold value: 0...
WatchDog does not receive signal for 14 seconds, value: 0

0 usb block device found
No Recording Partition Available !!!!!!
No Timeshift Partition Available !!!!!!

0 usb block device found
No Recording Partition Available !!!!!!
No Timeshift Partition Available !!!!!!
[cfyeh] set PPE = 0
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
[usb_param] setting for mars
Setting for MARS-B
[usb_param] set port two for host!
[usb1_param] usbphy reg 32, set sh = 0xf, get sh = 0xf, 4bit
[usb1_param] usbphy reg 35, set src = 0x7, get src = 0x7, 3bit
[usb1_param] usbphy reg 36, set senh = 0xd, get senh = 0xd, 4bit
[usb1_param] usbphy reg 32, set sen = 0x8, get sen = 0x8, 4bit
[usb1_param] usbphy reg 33, set dr = 0x0, get dr = 0x0, 3bit
[usb2_param] usbphy reg 32, set sh = 0xf, get sh = 0xf, 4bit
[usb2_param] usbphy reg 35, set src = 0x7, get src = 0x7, 3bit
[usb2_param] usbphy reg 36, set senh = 0xd, get senh = 0xd, 4bit
[usb2_param] usbphy reg 32, set sen = 0x8, get sen = 0x8, 4bit
[usb2_param] usbphy reg 33, set dr = 0x0, get dr = 0x0, 3bit
ohci_hcd ohci_hcd: OHCI Host Controller
ohci_hcd ohci_hcd: new USB bus registered, assigned bus number 2
ohci_hcd ohci_hcd: irq 2, io mem 0xb8013400
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
hub : no power switching (usb 1.0)
hub : no over-current protection

0 usb block device found
No Recording Partition Available !!!!!!
No Timeshift Partition Available !!!!!!

0 usb block device found
No Recording Partition Available !!!!!!
No Timeshift Partition Available !!!!!!

@@@[AbstractAP.cpp:1998:Init():19702]@@@

In my system...
This is the current time: PowerUP_Done!!!

@@@[AbstractAP.cpp:2007:Init():19781]@@@


@@@[AbstractAP.cpp:2015:Init():19782]@@@


@@@[AbstractAP.cpp:2021:Init():19861]@@@


@@@[AbstractAP.cpp:2030:Init():19862]@@@


@@@[AbstractAP.cpp:2037:Init():19875]@@@

In my system...
[System2ApDaemon.cpp,threadSys2ApExe,157]msg type = 2 ,msg len = 7 ,msg = 65 74 68 30 20 55 50 00
In my system...
sata1: reset phy extra!
sata phy reset
CheckNoHddModelSata0Connection false
CheckNoHddModelSata0Connection line=87, NoHddSata0OffCount=4
Key processed (296 ms).
In my system...
In my system...
CheckNoHddModelSata0Connection false
CheckNoHddModelSata0Connection line=87, NoHddSata0OffCount=5
Key processed (139 ms).
deleting routers
DtvState::xCheckEvents, No signal





***********************************************************
[CInputDTV.cpp 1620] set EVENT_FLUSH
SetPreviewMode to OFF success 1!!!
***********************************************************




flush TELETEXT begin
TTPinFlush...
TTPinFlush...return 1.
flush TELETEXT end
flush SPIC begin
flush SPIC end
flush AUDIO begin
[AUDIO WARNING] <4><APP> Reset cgms_change_flag when APP flush
=== GPIO 102, mute = 1
flush AUDIO end
flush VIDEO begin
flush VIDEO end
******** Updated PID Filter List ********
watchdog test pid 87, threshold: 50
adding dns 192.168.6.1
watchdog test pid 87, threshold: 50
Jan 1 00:07:00 login[245]: root login on `pts/0'

watchdog test pid 87, threshold: 50
sata1: phy reset timeout!
sata1: no device found (phy stat 00000000)
sata1: ata_bus_probe failed
scsi0 : SATA_DRV
sata dma reset
Pet67
 
Posts: 2
Joined: 25 Oct 2015, 18:12


Return to Совсем другие

Who is online

Users browsing this forum: No registered users and 4 guests