Page 1 of 1

Problem with 4TB HDD

PostPosted: 23 Apr 2018, 22:41
by douyi
Hi there,

I was trying to hook up a 4TB My Passport and it didn't recognize it, after check with fdisk -l and found the system recognizes the USB drive but doesn't recognize the partition, I tried to format the disk to two 2TB partitions in MBR but it doesn't recognized too. Tried with another 2TB My Passport (older one), with MBR has no problem, GPT even I have 512b per sector it still gave wrong size so it can't recognize too.

I'm running on the latest firmware (r13) with pohd skin, then after read old posts, decided to try r11 that claimed compatible with GPT, it's okay with 2TB GPT but can't recognize 4TB version, doesn't matter it's GPT or MBR.

I know Linux has NTFS-3G compatible with GPT, is it possible we add NTFS-3G support to firmware?


Re: Problem with 4TB HDD

PostPosted: 24 Apr 2018, 18:35
by lymax
for HDD over 2TB you MUST use GPT
you don't need NTFS-3G, if partition is less 2TB
--> you must make 2 partitions 2TB with GPT

Re: Problem with 4TB HDD

PostPosted: 25 Apr 2018, 23:46
by douyi
(cut) overquoting! Forum rules 4.19!

I tried GPT with one 2TB partition only (logical sector size is 512), two 2TB partitions and was not successful.

I also tried MBR with one 2TB partition and two 2TB partitions, didn't work out either.

My firmware version is v13, I installed amp_r12_vrtn_r7 first, tested not working, then using "USB upgrade" function from HMI upgraded to "amp_r13_nogui" (ordinary install version), then I upgraded and made sure all modules are latest.

Should I flash with original firmware, clear everything out then upgrade to "amp_r13_nogui" again?


Re: Problem with 4TB HDD

PostPosted: 26 Apr 2018, 15:19
by douyi
I decided trying from earlier version, start from v10. And v10 works! It only recognize MBR thou, but I can live with that, so the maximum capability will be 8TB in MBR I think.