Force HDMI output to stay active?

Force HDMI output to stay active?

Postby fullarmor » 05 Feb 2015, 09:49

Hi,

I have an old Xtreamer Pro and I flashed it with AMP r12. I tried to connect it to a Dell LCD monitor via an HDMI-to-VGA adapter, but the monitor just stays in sleep mode because HDMI port autodetect on the Xtreamer box thinks no monitor is connected via HDMI.

The HDMI-to-VGA adapter is the kind with audio phone jack output and uses the internal power fed from the HDMI port itself. I tested it on my PC and it works fine, so I'm pretty sure it's not a faulty adapter.

I found people facing the same problem on Raspberry Pi's forum, and someone suggested a solution by changing the "HDMI_safe = 1" in the config.txt file to force the HDMI port to stay active always. Is there a way to do the same with AMP r12?

Thanks in advance!
Xtreamer Pro (amp_r12_vrtn_r7)
fullarmor
 
Posts: 3
Joined: 05 Feb 2015, 09:32

Re: Force HDMI output to stay active?

Postby FarVoice » 05 Feb 2015, 11:40

Try to set video mode to 1080p60 , not HDMI auto
ASUS O!Play R1 (amp_r12_vrtn), xTreamer Pro (amp_r12_vrt), xTreamer Prodigy (iNeXT 2.14 r2), IconBIT HDR12L (amp_r12_vrt), 3Q F425HW (xds42gl_7725_r3), MyGica A11 (mygica_m3_20121222)
User avatar
FarVoice
Администратор
 
Posts: 8573
Joined: 03 Sep 2010, 01:27
Location: Russia, Moscow

Re: Force HDMI output to stay active?

Postby fullarmor » 05 Feb 2015, 22:45

I tried that, but unfortunately it's not working. Here's what happened:

With the HDMI-VGA adapter connected, the monitor is turned off in sleep mode. To get visual so I can go into settings and set video mode to 1080p 60Hz, I need to switch cable with a HDMI-DVI adapter (the monitor has dual input, 1 VGA and 1 DVI) and that works. Set the video mode, and switch back to HDMI-VGA, monitor goes back to sleep. I think every time I unplug/replug the HDMI port, the autodetect comes in play no matter what setting I choose in the video mode.

I also tried leaving the HDMI-VGA adapter connected to the monitor, and use the RCA composite cable to connect to TV at the same time for visual. Went in to the video mode settings, and "HDMI auto" option wasn't even there, and no matter what resolution I switch to (i.e. NTSC, 480p, 720P, 1080P), the PC monitor stays in sleep mode and never wake up.

Is there a config file that I can just hard code the AMP to keep HDMI live all the time?
Xtreamer Pro (amp_r12_vrtn_r7)
fullarmor
 
Posts: 3
Joined: 05 Feb 2015, 09:32

Re: Force HDMI output to stay active?

Postby FarVoice » 06 Feb 2015, 08:26

If your monitor have DVI connector, use HDMI-to-DVI cable. It's easiest way.
I don't know what to tweak in the system to the HDMI is not asleep :(
ASUS O!Play R1 (amp_r12_vrtn), xTreamer Pro (amp_r12_vrt), xTreamer Prodigy (iNeXT 2.14 r2), IconBIT HDR12L (amp_r12_vrt), 3Q F425HW (xds42gl_7725_r3), MyGica A11 (mygica_m3_20121222)
User avatar
FarVoice
Администратор
 
Posts: 8573
Joined: 03 Sep 2010, 01:27
Location: Russia, Moscow

Re: Force HDMI output to stay active?

Postby fullarmor » 06 Feb 2015, 20:11

'cause HDMI-DVI does not have audio output... I could use the RCA's L-R composite for audio, but I don't have any speaker that takes L-R composite input. HDMI-VGA w/ built-in audio output would be the best if I can get it working... Thanks for helping anyways.
Xtreamer Pro (amp_r12_vrtn_r7)
fullarmor
 
Posts: 3
Joined: 05 Feb 2015, 09:32


Return to About moServices

Who is online

Users browsing this forum: No registered users and 2 guests

cron